The official Rend servers are online. Please share your game feedback and bug reports with us!

Rend Dedicated Server

Kiwi✿Kiwi✿
edited September 2018 in General Discussion
Good Day,

Possibly the forum can help me.

I'm trying to run a Dedicated Rend Server for a few friends of mine,

This is all running of a Server i personally own but is Hosted by a Company, i can run other games with the same ports / Query Ports with success only rend has the issue

I Downloaded the game with the Steam CMD with the following parameter
@echo off
steamcmd +login anonymous +force_install_dir C:\RendServer +app_update 550790 -beta public +quit


once the entire CMD has finished its download, to run the game i used the following parameters

Attempt 1>
start "" /w /high "C:\RendServer\Otherlands\Binaries\Win64\OtherlandsServer-Win64-Shipping.exe" -BeaconPort=15000 -Port=7777 -nosteamclient -server -allowcheats -log

Attempt 2>
%~dp0Otherlands\Binaries\Win64\OtherlandsServer-Win64-Shipping.exe -log BeaconPort=15000 Port=7777 (from the rendserver.ba)


The ports are open (UDP / TCP).

The issue is the Server is visible, BUT when my friends attempt to connect it should bring up a details menu, this does not occur.

What am i doing wrong.

Restarts of the Server and Host have been done many times.


Game.ini
ServerName=Tenacious Gamers
ServerDescription=Tenacious Gamers
FactionLimit=20
WaveScheduleDays=(DayOfWeek=2,Hour=9,Minute=0)
WaveScheduleDays=(DayOfWeek=3,Hour=19,Minute=30)
ReckoningServerAgeRequirement=+00000001.00:00:00.000000000
bNoFactionShields=False
bNoFactionVictory=False
bPersonalTechTree=False
TrailingResearchBonus=0.10000
TrailingResearchBonus=0.10000
TreeDamageToSoulScalar=0.04
RareResourceHarvestMultiplier=1.000000
StackCountScalar=1.000000
PvpDamageMultiplier=1.000000
PveDamageMultiplier=1.000000
FriendlyDamageMultiplier=1.000000
PlayerSiegeDamageMultiplier=1.000000
EnvSiegeDamageMultiplier=1.000000
MaximumPlayTimeForDeleteMinutes=120.000000
MaximumDeletesPerAccount=1
PassiveScoreRatePerDay=0.02
CapturePointPassiveScoreRatePerDay=0.005

Have You Tried..... Well Nevermind

Comments

  • In my experience diagnosing this specific issue (server appears in list, but details can't be pulled up and it can't be connected to) it's a firewall/NAT/portforwarding issue. In few cases, I was able to narrow it down to routers that don't support nat loopback/reflection. Most of the time, it's improperly configured routers or system firewalls. Make sure that the system firewall is allowing the traffic on both ports and that both ports are being properly forwarded on the router.
  • Darinth wrote: »
    In my experience diagnosing this specific issue (server appears in list, but details can't be pulled up and it can't be connected to) it's a firewall/NAT/portforwarding issue. In few cases, I was able to narrow it down to routers that don't support nat loopback/reflection. Most of the time, it's improperly configured routers or system firewalls. Make sure that the system firewall is allowing the traffic on both ports and that both ports are being properly forwarded on the router.


    I've Solved the problem..

    It Seemed the Internal firewall on the actual host was having issues with Opening of ports TCP / UDP, i went and cleared all Custom Ports and re-configured them based port range instead of specific ports. The Server is now running properly and people can play, the fact it was visible and unable to be connected to, shows that the Query Port was open whereas the actual "home" port where people connect to and play was being refused by the firewall even with the port being opened.

    Have You Tried..... Well Nevermind
  • The server establishes an outbound connection to FK's index server in order to show up in the list. Because that's an outbound connection, most firewalls by default allow it and there's nothing special you have to do. It also means that both the query port and main port can be blocked and you'll still show up in the list. However, I'm assuming when you clicked on it you never got details and weren't able to connect? If it pulls up details, that means the query port is able to be connected to. If you can see details but the connection fails when you actually try to connect, that means the main server port isn't visible.
  • Spoke with the host / provider of the actual network connection, with the original Firewall configuration, below are the ports that never communicated with their firewall, so this led me to reconfigure the servers internal firewall.

    %<
    PORT STATE SERVICE
    7777/tcp filtered cbt
    15000/tcp filtered hydap
    %<
    Have You Tried..... Well Nevermind
Sign In or Register to comment.